Installation Instructions

  1. Map the network drive found in the "Pulse Secure" Software Library Entry (see Related Items)
  2. Install the necessary package
    • Debian - based installation command: dpkg -i
    • RPM - based installation command: rpm -ivh
  3. Once installed, run the Dependencies Installation Command
    • 64-bit Machines: /usr/local/pulse/PulseClient_x86_64.sh install_dependency_packages
    • 32-bit Machines: /usr/local/pulse/PulseClient.sh install_dependency_packages
    • Fedora 28 also requires: dnf install compat-libicu57
    • Xubuntu 18.04 LTS also requires: apt-get install libwebkitgtk-1.0-0 libjavascriptcoregtk-1.0-0

Launch UI from Application

Use the Pulse Secure Application

Launch UI from Terminal

  • Append /usr/local/pulse to LD_LIBRARY_PATH:
  • Launch the UI by executing:

Configure the VPN Client

After you have installed and launched Pulse Secure, add a new connection profile by following these steps:

  1. Click on the plus sign next to the "Connect" label
  2. Select "UAC or SSL-VPN" for the Type
  3. Type "Default VPN" for the Name
  4. Type https://vpn.wpi.edu for the Server
  5. Click the "Add" button to save the profile

The profile just added should appear in the menu on the main screen. Click on the connect button to complete the login process. Be sure to use your full WPI email address as your login.

Requirements

Pulse Secure Qualified Systems: The platforms listed as qualified have been systematically tested by the Pulse Secure Quality Assurance department as part of this release.

  • Ubuntu 17.10, 64-bit
  • Ubuntu 16.04.04, 64-bit and 32-bit
  • Debian 9.4, 64-bit and 32-bit
  • Cent OS 7.4, 64-bit
  • RHEL 7.4, 64-bit
  • Fedora 27, 64-bit and 32-bit

Pulse Secure Compatible Systems: The platforms listed as compatible have not been systematically tested by our QA department in this release; however, Pulse Secure expects that the Pulse functionality will work based on testing of previous releases and knowledge of the platform.

  • Ubuntu 17.x, 64-bit
  • Ubuntu 16.x, 64-bit and 32-bit
  • Debian 9.x, 64-bit and 32-bit
  • Debian 8.x, 64-bit and 32-bit
  • Cent OS 7.x, 64-bit
  • Cent OS 6.x, 64-bit and 32-bit
  • RHEL 7.x, 64-bit
  • Fedora 26, 64-bit and 32-bit